Konfiguracja sieci:

Są 2 łącza internetowe z podziałem na usługi:

- http, https -> WAN2

- reszta -> WAN1

wg opisu: http://wiki.mikrotik.com/wiki/Per-Traffic_Load_Balancing

W tym przypadku jeśli WAN są podłączone po Ethernet poprzez 2 inne routery realizujące np połączenie pppoa (nie obsługiwane w miktorik) to w routingu zawsze będą aktywne ścieżki do bram a mimo to łącza mogą nie działać ze względu na awarie ADSL.

Tworzymy 2 statyczne trasy do badania łącza:

/ip route
add disabled=no distance=1 dst-address=212.77.100.101/32 gateway=192.168.254.254 scope=30 target-scope=10
add disabled=no distance=1 dst-address=213.180.146.27/32 gateway=192.168.253.254 scope=30 target-scope=10

gdzie:

192.168.254.254 - Gateway WAN 1

192.168.253.254 - Gateway WAN 2

Adresy: 212.77.100.101 oraz 213.180.146.27 to dowolne jakie chcemy badać celem dostępności łącza.

Do route domyślnych tras (0.0.0.0/0) dodałem komentarze WAN1 oraz WAN2 np:

/ip route
add comment=WAN1 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.253.254 routing-mark=WAN-01 scope=255 target-scope=10
add comment=WAN2 disabled=no distance=1 dst-address=0.0.0.0/0 gateway=192.168.254.254 routing-mark=WAN-02 scope=255 target-scope=10

Za pomocą narzędzia netwatch sprawdzam dostępność adresów do testowania łącza:

/tool netwatch
add comment="Sprawdzanie WAN 1" disabled=no down-script="/log info \
\"WAN1 DOWN\"\r\
\n/ip route set [find comment=\"WAN1\"] disabled=yes" host=\
212.77.100.101 interval=10s timeout=1s up-script="/log info \"WAN1 UP\
\"\r\
\n/ip route set [find comment=\"WAN1\"] disabled=no"
add comment="Sprawdzanie WAN 2" disabled=no down-script="/log info\
\_\"WAN2 DOWN\"\r\
\n/ip route set [find comment=\"WAN2\"] disabled=yes" host=\
213.180.146.27 interval=10s timeout=1s up-script="/log info \"WAN2 UP\
\"\r\
\n/ip route set [find comment=\"WAN2\"] disabled=no"

Powyższy skrypt sprawdza dostępność danych adresów w internecie łączem WAN 1 albo WAN 2 i jeśli któryś nieaktywny to wyłącza trasy routingu z komentarzami WAN1 lub WAN2. Po powrocie łącza trasa jest włączana.

Tagi